Re: @@Jit Attribute Considerations
| From: | Benjamin Eberlei | Date: | Tue, 04 Aug 2020 07:15:43 +0000 |
| Subject: | Re: @@Jit Attribute Considerations | ||
| References: | 1 2 3 4 5 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-111306@lists.php.net to get a copy of this message | ||
Alternatively make it @@Jit("off") only and any other argument will lead to
an error for now.
Then the problem left becomes "Jit" being a very short global class.
On Mon, Aug 3, 2020 at 10:36 PM Benas IML <benas.molis.iml@gmail.com> wrote:
>
@@NoJit sounds pretty alright to me.
>
> On Mon, Aug 3, 2020, 11:27 PM Derick Rethans <derick@php.net> wrote:
>
>> On 3 August 2020 20:20:35 BST, Benjamin Eberlei <kontakt@beberlei.de>
>> wrote:
>>
>> >In that case maybe we should rename the attribute to @@DisableJit ?
>> >This
>> >would not clutter the global namespace with a "jit" class.
>>
>> Things with a negative name are usually a code smell. I'm not keen on a
>> @[disableJit] attribute name.
>>
>> cheers,
>> Derick
>>
>> --
>> PHP Internals - PHP Runtime Development Mailing List
>> To unsubscribe, visit: https://www.php.net/unsub.php
>>
>>