Re: alternative syntax for do...while
| From: | Marc Richards | Date: | Tue, 13 Jul 2004 15:34:33 +0000 |
| Subject: | Re: alternative syntax for do...while | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-11177@lists.php.net to get a copy of this message | ||
Red Wingate wrote:
Marc Richards wrote:It is, and that is what I currently do, but <?php if ($x == TRUE){ ?> <tr>I guess this is too late for 5.0, and I feel like there is bound to be opposition, but this has been bugging me for a while, so I figured I would ask. I use the alternative syntax for control structures almost exclusively within my HTML code but I have to revert to braces for do...while. Why can't we do this? <? do: ?> <tr> <td><?= $s_array['name'] ?></td> <td><?= $s_array['classyear'] ?></td> <td><?= $s_array['status'] ?></td> </tr> <? while ($s_array = mysql_fetch_array($search_results): ?> <? enddowhile ?> It is a little cumbersome, but at least I can keep my syntax consistent. Are there parser related problems? Marc<?php do { ?> <tr><td><?= $s_array['name'] ?></td> <td><?= $s_array['classyear'] ?></td> <td><?= $s_array['status'] ?></td></tr> <?php } while ($s_array = mysql_fetch_array($search_results); ?> is much shorter, ain't it ?
<td><?= $s_array['name'] ?></td>
<td><?= $s_array['classyear'] ?></td>
<td><?= $s_array['status'] ?></td>
</tr>
<? } ?>
Is generally less readable (especially in a large page) than:
<?php if ($x == TRUE): ?>
<tr>
<td><?= $s_array['name'] ?></td>
<td><?= $s_array['classyear'] ?></td>
<td><?= $s_array['status'] ?></td>
</tr>
<? endif ?>
And I was looking for some consistency...not necessarily brevity.
Marc