Re: [VOTE] Deprecate dynamic properties

From: Date: Sun, 14 Nov 2021 16:42:14 +0000
Subject: Re: [VOTE] Deprecate dynamic properties
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-116346@lists.php.net to get a copy of this message
On 14/11/2021 11:48, Pierre Joye wrote:
Also I do see it as a kind of strict mode addition and the depreciation as well could be strict mode only.
A quick reminder that PHP has no "strict mode". It has a "strict_types" declaration, which is probably misnamed, and should be something like "scalar_types=error" vs "scalar_types=coerce". Suggestions to add a more general "two modes for the whole language" approach have generally gone down in flames. Suggestions to add other declarations tend to run into discussions of namespace-scoped declares / project configuration / etc Regards, -- Rowan Tommins [IMSoP]

« previous php.internals (#116346) next »