Re: [RFC] Unicode Text Processing

From: Date: Fri, 16 Dec 2022 05:09:49 +0000
Subject: Re: [RFC] Unicode Text Processing
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-119164@lists.php.net to get a copy of this message
On 2022-12-15 8:34 AM, Derick Rethans wrote:
Hi, I have just published an initial draft of the "Unicode Text Processing" RFC, a proposal to have performant unicode text processing always available to PHP users, by introducing a new "Text" class. You can find it at: https://wiki.php.net/rfc/unicode_text_processing I'm looking forwards to hearing your opinions, additions, and suggestions — the RFC specifically asks for these in places. cheers, Derick I love the idea, but we may want to think about using the terms
trimStart and trimEnd instead of trimLeft and trimRight. Obviously, when the text in the parameter is in a right-to-left language (e.g., Hebrew, Arabic), trimLeft and trimRight are going to do the opposite of what one may expect from the names of the functions. I know that identifiers like ltrim and rtrim are longstanding conventions which everyone understands that they **really** mean trimming from the start and end respectively, but this may be an opportunity to amend the inaccuracy. If this ever gets expanded to add padding functions, those should probably be named padStart and padEnd as well.

« previous php.internals (#119164) next »