Re: [RFC] New core autoloading mechanism with support for function autoloading
| From: | Ondřej Mirtes | Date: | Mon, 10 Apr 2023 13:00:40 +0000 |
| Subject: | Re: [RFC] New core autoloading mechanism with support for function autoloading | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-119857@lists.php.net to get a copy of this message | ||
I don’t like the proposed function names:
autoload_register_class to me reads like “register this class for
autoloading”. If I observe the intended meaning correctly, it should be
called “register_class_autoloader”.
Same for autoload_register_function - better name would be
“register_function_autoloader”.
Other functions should be renamed accordingly. Function names should read
like a sentence, like a command.
On Mon 10. 4. 2023 at 14:17, G. P. B. <george.banyard@gmail.com> wrote:
> Hello Internals,
>
> Dan and I would like to propose a new core autoloading mechanism that fixes
> some minor design issues with the current class autoloading mechanism and
> introduce a brand-new function autoloading mechanism:
> https://wiki.php.net/rfc/core-autoloading
>
> The existing SPL autoloading functions would become aliases to the new Core
> ones and will continue to work without any migrations needing to be
> performed.
>
> Hope to hear your opinions about this!
>
> Best regards,
>
> George P. Banyard
>
--
Ondřej Mirtes