Re: RFC1867 (multipart/form-data) PUT requests
| From: | Ben Ramsey | Date: | Mon, 26 Jun 2023 18:54:08 +0000 |
| Subject: | Re: RFC1867 (multipart/form-data) PUT requests | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-120684@lists.php.net to get a copy of this message | ||
> On Jun 20, 2023, at 06:06, Rowan Tommins <rowan.collins@gmail.com> wrote:
>
> On Tue, 20 Jun 2023 at 10:25, Ilija Tovilo <tovilo.ilija@gmail.com> wrote:
>
>> Introduce a new function (currently named populate_post_data()) to
>> read the input stream and populate the $_POST and $_FILES
>> superglobals.
>>
>
>
> My initial instinct was to discuss how this could be made more flexible in
> terms of input and output; but looking at how simple the implementation is,
> this seems like a really quick win, and anything else can be future scope.
>
> To bikeshed the name a bit:
>
> * We should probably avoid the word "post"; although it populates $_POST,
> that's really misnamed anyway, what we're really talking about is "form
> data"
> * Even if there isn't a current category prefix where it belongs, it should
> probably follow the "category_specific" naming scheme
> * We might in future add some related functions, such as returning the data
> rather than populating globals
>
> How about "request_form_populate_globals"?
Another option for the name:
Attachment: [application/pgp-signature] Message signed with OpenPGP signature.asc
populate_multipart_form_data().
Cheers,
Ben
Attachment: [application/pgp-signature] Message signed with OpenPGP signature.asc