Re: [RFC] Static Constructor
| From: | Erick de Azevedo Lima | Date: | Wed, 19 Jun 2024 14:03:57 +0000 |
| Subject: | Re: [RFC] Static Constructor | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-123677@lists.php.net to get a copy of this message | ||
Hi, Michał.
> Have you considered naming it for example shortly
function
> __static() ?
I have considered some names, actually. I just chose this one for the
implementation because
I tried to design it to be as close as possible to the C# implementation
and they call it "static constructor".
But the name can be changed to another one without any problem at all.
Regards,
Erick