Re: [RFC] [Discussion] array_get and array_has functions
| From: | Barel | Date: | Thu, 16 Apr 2026 05:45:04 +0000 |
| Subject: | Re: [RFC] [Discussion] array_get and array_has functions | ||
| References: | 1 2 3 4 5 6 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-130658@lists.php.net to get a copy of this message | ||
On Wed, 15 Apr 2026 at 19:58, Tim Düsterhus <tim@bastelstu.be> wrote:
> Hi
>
> Am 2026-04-14 19:06, schrieb Barel:
> > BTW, the URL to the RFC has changed and is now
> > https://wiki.php.net/rfc/array_get_path_and_array_has_path
>
> Please don't create new RFC documents for the same RFC. This breaks the
> version history and is super confusing, because the link in the
> discussion thread will go to an abandoned version of the RFC. In fact
> you forgot to adjust the link in the RFC overview at:
> https://wiki.php.net/rfc
>
> Having an outdated name of the feature in the URL is fine - and typos
> are as well. The latter happened with my #[\Override] RFC, where I
> accidentally dropped the 'd' in 'overridden':
> https://wiki.php.net/rfc/marking_overriden_methods. Note how I
> also
> “described” the proposed feature in the RFC and the title - this was to
> make it independent of any naming bikeshedding that might happen :-)
>
> Best regards
> Tim Düsterhus
>
Thanks, I have recovered the previous RFC and updated it with the latest
changes
https://wiki.php.net/rfc/array_get_and_array_has
Cheers
Carlos