Re: [RFC] Function Autoloading (mark 5)

From: Date: Wed, 15 Jul 2026 18:35:25 +0000
Subject: Re: [RFC] Function Autoloading (mark 5)
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-131945@lists.php.net to get a copy of this message
Hi all, > On Jul 14, 2026, at 19:57, Paul M. Jones <pmjones@pmjones.io> wrote: > > > >> On Jul 13, 2026, at 15:08, Paul M. Jones <pmjones@pmjones.io> wrote: >> >> Hi Tim, >> >> >>> On Jul 13, 2026, at 13:04, Tim Düsterhus <tim@bastelstu.be> wrote: >>> >>> I believe the strict_namespace=1 directive is a >>> sufficiently unrelated concern - with enormous bikeshedding potential on its own [1], but also >>> sufficient usefulness on its own - such that I feel it should be its own RFC that is a prerequisite >>> to this one. It should not be piggy-backed onto function autoloading. >> >> I'm good with that. I'll prepare a separate RFC and remove that from the >> function-autoloading one. > > Done: https://wiki.php.net/rfc/strict-namespace > > I will update the function autoloading RFC as needed to refer back to strict-namespace instead > of incorporating it. The RFC has been updated to un-incorporate the strict-namespace elements; if there are no further substantive comments, I would like to open the vote in 2-ish weeks. -- pmj

« previous php.internals (#131945) next »