Re: Before March 1st aka PHP 5.1 beta

From: Date: Thu, 17 Feb 2005 19:59:35 +0000
Subject: Re: Before March 1st aka PHP 5.1 beta
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-15056@lists.php.net to get a copy of this message
> 4) php 5.1 is aiming to increase performance and security => ifsetor > > It is nice and easy and fast...only it's name. Well guys come on that's > the stupiest reason to reject. The name is selfspeaking, you're all only > not so used to its name as you are with foreach for now. I really love this idea a lot, but I hope there will be an ifemptyor() as well.. Maybe these names could be considered: "setor" and "emptyor" setor($foo, "bar"); emptyor($foo, "bar"); or if they won't be call by reference: $foo = setor($foo, "bar"); $foo = emptyor($foo, "bar"); I really like this idea, and I don't know if it will be by-reference, but if they would, then I think it would be nice to have them return a boolean which is False if the alternative was used and True otherwise. Just my 0.02 euro. Ron

« previous php.internals (#15056) next »