Re: Re: new overloading feature?

From: Date: Thu, 12 May 2005 21:48:16 +0000
Subject: Re: Re: new overloading feature?
References: 1 2 3 4 5 6  Groups: php.internals 
Request: Send a blank email to internals+get-16234@lists.php.net to get a copy of this message
Hello Alex, but PHP is a class based langauage which is very much different from prototype based langauages. Apart from that i already said that it would be possible to add a special 'called_self' (or better name) syntax to support what you want - only that would slow doen execution even if you won't use it. And since what you want is not the correct way of doing it in a class based language i don't think we should add it. regards marcus Tuesday, May 10, 2005, 6:33:55 PM, you wrote: > 2005/5/10, Sebastian Bergmann <sb@sebastian-bergmann.de>: >> Lukas Smith wrote: >> > http://bugs.php.net/bug.php?id=30235 >> >> I agree with Marcus: self is bound at runtime, so the behaviour is >> correct. If you do not like this late binding just do not use self but >> the name of the class. > I don't agree with Marcus. Singleton or the name of the class are ugly > workarounds for this bug. Every genuine OOP and dynamic language > (ObjC, Ruby, Smalltalk) bounds self at runtime. > -- > PHP Internals - PHP Runtime Development Mailing List > To unsubscribe, visit: http://www.php.net/unsub.php -- Best regards, Marcus mailto:mail@marcus-boerger.de

« previous php.internals (#16234) next »