Re: Re: new overloading feature?
| From: | Alex Knaub | Date: | Fri, 13 May 2005 15:18:43 +0000 |
| Subject: | Re: Re: new overloading feature? | ||
| References: | 1 2 3 4 5 6 7 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-16238@lists.php.net to get a copy of this message | ||
2005/5/12, Marcus Boerger <mail@marcus-boerger.de>:
> Hello Alex,
>
> but PHP is a class based langauage which is very much different from
what is a class based language?
> prototype based langauages. Apart from that i already said that it would be
> possible to add a special 'called_self' (or better name) syntax to support
> what you want - only that would slow doen execution even if you won't use
> it. And since what you want is not the correct way of doing it in a class
that is the only correct way to use factories in a dynamic language,
everything else
leads to code duplication and / or crapy code.