Re: RE: [PHP-DEV] RFC: PHP OO API naming convention

From: Date: Tue, 20 May 2003 12:44:09 +0000
Subject: Re: RE: [PHP-DEV] RFC: PHP OO API naming convention
Groups: php.internals 
Request: Send a blank email to internals+get-1781@lists.php.net to get a copy of this message
Current: $foo->execute_query($query, $param); I think, current standart is "PHP" standart. New: $foo->executeQuery($query, $param); New standart is somethink like DELPHI or C++. Big problem is PHP is case sensitive. executeQuery and executequery is NOT same. PHP use another naming convencion as substitute. I think it's better for users. I choose old standart. Jan Sun > > From: Lukas Smith [mailto:smith@backendmedia.com] > > Sent: Tuesday, May 20, 2003 1:04 PM > > > This is a follow up of a previous thread but this time I will give it > > the RFC label to make it more official: > > > > http://marc.theaimsgroup.com/?l=php-dev&m=105299997308470&w=2 > > > > I am proposing the use of studlyCaps as the CS standard for object > > oriented API's exposed by PHP extensions. > > I was just informed that I am making this more complex than they need to > be and that the first thread was enough. I will make the necessary > modifications to the CODING_STANDARDS and will get someone to commit > this. > > Regards, > Lukas > > > -- > PHP Internals - PHP Runtime Development Mailing List > To unsubscribe, visit: http://www.php.net/unsub.php > ====================== REKLAMA ================================= Získajte supervýhodné ADSL ešte výhodnejšie v cenovom odpočítavaní Slovanet ADSL Teraz! Čím skôr sa rozhodnete, tým viac ušetríte. http://www.slovanet.sk/menu/adsl.html

« previous php.internals (#1781) next »