Re: RFC: PHP OO API naming convention
| From: | Alan Knowles | Date: | Tue, 20 May 2003 13:11:05 +0000 |
| Subject: | Re: RFC: PHP OO API naming convention | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-1783@lists.php.net to get a copy of this message | ||
Ján Šuňavec wrote:
Current: $foo->execute_query($query, $param); I think, current standart is "PHP" standart.Regards AlanNew: $foo->executeQuery($query, $param); New standart is somethink like DELPHI or C++. Big problem is PHP is case sensitive. executeQuery and executequery is NOT same.Actually PHP funcitons are case INSENSITIVE, you will find many an interesting read about this subject on the mailing list. (eg. executequery and executeQuery are the same..)
PHP use another naming convencion as substitute. I think it's better for users. I choose old standart.-- Can you help out? Need Consulting Services or Know of a Job? http://www.akbkhome.com