Re: [PATCH] Late Static Binding (Take 2)
| From: | Andi Gutmans | Date: | Thu, 09 Mar 2006 00:21:40 +0000 |
| Subject: | Re: [PATCH] Late Static Binding (Take 2) | ||
| References: | 1 2 3 4 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-22264@lists.php.net to get a copy of this message | ||
Yeah I agree but I'm less concerned about the naming at this point but how to implement it assuming we find a name.
Andi
At 04:18 PM 3/8/2006, David Zülke wrote:
I'd still say we make it "this". It's reasonable and consistent. - David Am 09.03.2006 um 01:13 schrieb Andi Gutmans:This patch is a bit rough. I'll try and think if there's a more elegant way. Andi At 01:06 PM 3/8/2006, Mike Lively wrote:1) I would very like to see some real example where "static" isOn Wed, 2006-03-01 at 17:37 +0300, Dmitry Stogov wrote:2) "static" is really bad name. I suggest "caller", Marcusnecessary?"class". 3) I COMPLETELY DISAGREE TO ADD RUNTIME DATA INTO zend_function/zend_op_array. We can try to store "caller_scope" in execute_data. Thanks. Dmitry.thought aboutRewrote the patch to use execute_data to store caller_scope. I have not renamed any functions or keywords (still using static::) as I did not see any consensus on that yet. Please review the implementation of caller_scope and I can take care of the naming issues when names are decided on. patch attached and also available at http://test.ft11.net/_mlively/late-static-binding.patch It would be nice if the patch in PAT could be changed to reference this new version if the appropriate people have time.-- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php