Re: Re: [ZEND-ENGINE-CVS] cvs: ZendEngine2 / zend_API.c

From: Date: Tue, 18 Apr 2006 17:30:15 +0000
Subject: Re: Re: [ZEND-ENGINE-CVS] cvs: ZendEngine2 / zend_API.c
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-22837@lists.php.net to get a copy of this message
On 18.04.2006 21:24, Pierre wrote:
On Tue, 18 Apr 2006 10:15:42 -0700 andi@zend.com (Andi Gutmans) wrote:
Do we really need this? I'd prefer to keep "string" and "unicode"
I was asking the same thing. We should have only two names, as we have actually only two types, binary and unicode. I'm in favour of naming it "binary string" instead of simply "string". No confusion, "string" will always be confusing, unicode mode or not.
I'd say we need to change "Unicode string" to "string" in non-Unicode mode too. There is no "binary" strings in this case, so using such names would be very confusing. -- Wbr, Antony Dovgal

« previous php.internals (#22837) next »