Re: cvs: php-src /ext/unicode locale.c
| From: | Andrei Zmievski | Date: | Tue, 18 Apr 2006 22:19:36 +0000 |
| Subject: | Re: cvs: php-src /ext/unicode locale.c | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-22847@lists.php.net to get a copy of this message | ||
We had this discussion a long time ago. I don't mind revisiting the naming conventions, but I want them to be consistent. Consider that Derick added collator_create() and collator_sort(). Should we have collator_get_default(), collator_set_default(), and respectively, locale_get_default(), locale_set_default()? What about other ICU services?
-Andrei
On Apr 18, 2006, at 3:15 PM, Antony Dovgal wrote:
I'd say i18n_loc_get_default() and i18n_loc_set_default() are the ugliest names I've ever saw =) default_locale_set() and default_locale_get() would be MUCH more readable and clear.