Re: Re: cvs: php-src /ext/unicode locale.c

From: Date: Wed, 19 Apr 2006 21:38:08 +0000
Subject: Re: Re: cvs: php-src /ext/unicode locale.c
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-22884@lists.php.net to get a copy of this message
Hmm, no replies. Okay, making executive decision then.. Don't complain later. -Andrei On Apr 18, 2006, at 3:19 PM, Andrei Zmievski wrote:
We had this discussion a long time ago. I don't mind revisiting the naming conventions, but I want them to be consistent. Consider that Derick added collator_create() and collator_sort(). Should we have collator_get_default(), collator_set_default(), and respectively, locale_get_default(), locale_set_default()? What about other ICU services? -Andrei On Apr 18, 2006, at 3:15 PM, Antony Dovgal wrote:
I'd say i18n_loc_get_default() and i18n_loc_set_default() are the ugliest names I've ever saw =) default_locale_set() and default_locale_get() would be MUCH more readable and clear.
-- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php


« previous php.internals (#22884) next »