RE: [PHP-DEV] 5.2.4RC1 Released
| From: | Uwe Schindler | Date: | Fri, 03 Aug 2007 10:07:41 +0000 |
| Subject: | RE: [PHP-DEV] 5.2.4RC1 Released | ||
| References: | 1 2 3 4 5 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-31401@lists.php.net to get a copy of this message | ||
> >> Cannot reproduce this, configure went just fine on Solaris.
> >> Can you please see on which line in configure script it complains?
> >
> > How can I find that out? Is there a debug parameter? Config.log does not
> > show anything.
> >
> > Could it be that on your solaris system the default shell in /bin/sh is
> > "bash"?
>
> It's definitely not bash (cause I have to run bash manually to get a
> usable shell).
>
> # ls -l /bin/sh
> -r-xr-xr-x 4 root root 95320 Jul 30 2004 /bin/sh
pangaeaw@pansrv1:~/install/php-5.2.4RC1$ ls -l /bin/sh
lrwxrwxrwx 1 root root 13 Apr 13 10:40 /bin/sh ->
../../sbin/sh
pangaeaw@pansrv1:~/install/php-5.2.4RC1$ ls -l /sbin/sh
-r-xr-xr-x 1 root root 82468 Oct 18 2006 /sbin/sh
Until now, I have no error location. I think I will look into the changes in
configure.in and look for test calls and try to modify them.
Starting configure with sh -v did not work it only prints a few messages at
beginning but then switches to another shell (???). The problem is fixed if
you start configure with "bash configure". But it would be good to fix this.
> > You are right with CLI it works. But there seems to be a problem with
> INI
> > parsing. The web application that produced this error was started with
> an
> > overwritten "error_reporting" value running in Sun Java System Webserver
> > which worked correctly with 5.2.3:
> >
> > Service fn="php5_execute" type="magnus-internal/x-httpd-php"
> > error_reporting="2039" allow_url_include="1"
>
> This works just fine either:
> ./sapi/cli/php -d error_reporting=2039 -r 'error_reporting(2039);
> @fopen("aaaa", "r");
>
> No idea how the sun webserver passes options to PHP, though.
I looked into it:
The problem seems to be ZTS specific.
What we have:
* First, the value looks correct in phpinfo().
* Second setting the value to 6039 (which is the default from php.ini)
produces now a lot of _more_ and very strange error messages when running
PHP scripts.
It seems that the webserver puts the value somewhere to a global place
because after that *ALL* PHP scripts print very strange things (even those
where this value is not explicitely set).
Could it be that there happened a ZTS regression when updating the ini
scanner? In 5.2.3 it worked correctly.
I think I write now a bug report and paste this mail conversation into it.