Re: 5.2.4RC1 Released
| From: | Antony Dovgal | Date: | Fri, 03 Aug 2007 10:25:51 +0000 |
| Subject: | Re: 5.2.4RC1 Released | ||
| References: | 1 2 3 4 5 6 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-31410@lists.php.net to get a copy of this message | ||
On 03.08.2007 14:07, Uwe Schindler wrote:
Until now, I have no error location. I think I will look into the changes in configure.in and look for test calls and try to modify them.Thanks.
Starting configure with sh -v did not work it only prints a few messages at beginning but then switches to another shell (???). The problem is fixed if you start configure with "bash configure". But it would be good to fix this.Yes, I've already CCed Jani, who's responsible for this part.
I looked into it: The problem seems to be ZTS specific. What we have: * First, the value looks correct in phpinfo(). * Second setting the value to 6039 (which is the default from php.ini) produces now a lot of _more_ and very strange error messages when running PHP scripts. It seems that the webserver puts the value somewhere to a global place because after that *ALL* PHP scripts print very strange things (even those where this value is not explicitely set).How EXACTLY does the web-server put the value? To me it looks like you're using some global config file, so no wonder it's put globally.
Could it be that there happened a ZTS regression when updating the ini scanner? In 5.2.3 it worked correctly.I don't know what exactly is the problem and how to reproduce it, so it makes little sense to ask _me_ about it. Do you have a short reproduce case that doesn't require Solaris, Sun Web server and other stuff we don't have? -- Wbr, Antony Dovgal