PHP5 - OO extensions and naming conventions.
| From: | l0t3k | Date: | Wed, 02 Jul 2003 14:37:49 +0000 |
| Subject: | PHP5 - OO extensions and naming conventions. | ||
| Groups: | php.internals | ||
| Request: | Send a blank email to internals+get-3166@lists.php.net to get a copy of this message | ||
IIRC there was an informal consensus to use studlyCaps as the official
userland convention for OOP extensions (*) (leaving aside the case
insensitivity of the language.)
my question now concerns accessors. should we prefer properties over
propertyGet()/propertySet() accessor functions ? would having both
constitute bloat. i ask because im implementing a series of classes
mirroring those in the Caffeinated Language (tm) so familiarity could be an
asset.
l0t3k
(*) i wonder if this should be more formalized before the next major
release. major extensions like dom/xsl are already using the current
method->function_ name() convention.