Re: [RFC] Strict type hints (parameter and return value)
| From: | Lars Strojny | Date: | Fri, 18 Apr 2008 06:39:42 +0000 |
| Subject: | Re: [RFC] Strict type hints (parameter and return value) | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-37123@lists.php.net to get a copy of this message | ||
Hi Felipe,
Am Donnerstag, den 17.04.2008, 21:24 -0300 schrieb Felipe Pena:
[...]
> But i think that is<type> as name is confuse in this case.
> We need a name for that.
isOfType(), just is() or isA() (and than also allowing classnames) or
maybe getType(), similiar to the currently existing getClass().
getType() would return the type as a string, so one could do
$reflected->getType() == 'string'. Anyway, just thinking loud ...
cu, Lars
Attachment: [application/pgp-signature] Dies ist ein digital signierter Nachrichtenteil signature.asc
Attachment: [application/pgp-signature] Dies ist ein digital signierter Nachrichtenteil signature.asc