Re: CVS Account Request
| From: | Antony Dovgal | Date: | Wed, 23 Apr 2008 07:43:37 +0000 |
| Subject: | Re: CVS Account Request | ||
| References: | 1 2 3 4 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-37195@lists.php.net to get a copy of this message | ||
On 17.04.2008 18:50, Tatsuo Ishii wrote:
Here are the patches against 5.2 HEAD.First of all, please use
diff -u, not just diff - unified diffs are much more readable.
Modified API's are: 1) pg_lo_create now accepts an optional parameter (large object id). This corresponds to lo_create() which is new in PostgreSQL 8.1. 2) new API: pg_lo_import_with_oid. Same as pg_lo_import except that it accepts large object id. This corresponds to lo_import_with_oid() which is new in PostgreSQL 8.4 (current).Is there a real need for a new function? Can't we modify pg_lo_import() to accept one more argument? -- Wbr, Antony Dovgal