Re: Re: Short syntax for array literals [...]
| From: | Antony Dovgal | Date: | Wed, 28 May 2008 07:42:06 +0000 |
| Subject: | Re: Re: Short syntax for array literals [...] | ||
| References: | 1 2 3 4 5 6 7 8 9 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-37950@lists.php.net to get a copy of this message | ||
On 28.05.2008 11:34, Stanislav Malyshev wrote:
Hi!Yeah, from Javascript to PHP just because of better syntax. HA.I don't recall any languages to introduce new syntax because it's so handy to those who come from PHP and I see no reasons for us to do it either.If they don't do it and we do, people come from them to us and not the reverse.
The reason is to make life easier for people. And I think current results - 21:8 - tell something.Want me to find some more 50 people to vote against it? We're having a conference these days, I believe I can find even more people just to show you how meaningless these votes are =)
I do not and will not believe that you - or anybody smart enough to use PHP - would seriously have any trouble understanding what that means. Arguing it is extraneous is one thing, but presenting PHP users as senseless robots hopelessly confused by even simplest concepts like using [] for arrays just doesn't make any sense.Wasn't that the main reason FOR adding this syntax? The array() thing seems to you too hard to read and maintain, no? If it's not, than I don't see what you're arguing for. -- Wbr, Antony Dovgal