Re: Re: Short syntax for array literals [...]

From: Date: Wed, 28 May 2008 08:03:14 +0000
Subject: Re: Re: Short syntax for array literals [...]
References: 1 2 3 4 5 6 7 8 9 10  Groups: php.internals 
Request: Send a blank email to internals+get-37951@lists.php.net to get a copy of this message
Hi!
Want me to find some more 50 people to vote against it?
If you find 50 active commiters against it - I think it'd make sense to hear what they have to say. Ask them why they didn't say anything by now.
We're having a conference these days, I believe I can find even more people just to show you how meaningless these votes are =)
OK, they are meaningless. What is meaningful?
Wasn't that the main reason FOR adding this syntax? The array() thing seems to you too hard to read and maintain, no?
Yes. In many cases new one is better than the old one. In some cases, it might not be - but nobody proposes to remove array(). One can find a way to mangle almost any syntax - that's not the point. The point is that it *is* useful in a lot of cases. -- Stanislav Malyshev, Zend Software Architect stas@zend.com http://www.zend.com/ (408)253-8829 MSN: stas@zend.com

« previous php.internals (#37951) next »