[PATCH] Alias stream_context_get_default() as stream_context_set_default()
| From: | Davey Shafik | Date: | Sun, 03 Aug 2008 23:29:15 +0000 |
| Subject: | [PATCH] Alias stream_context_get_default() as stream_context_set_default() | ||
| Groups: | php.internals | ||
| Request: | Send a blank email to internals+get-39586@lists.php.net to get a copy of this message | ||
Hey,
it has come to my attention that stream_context_get_default() is /grossly/ misnamed, considering
that it can be used (and is the only way) to SET default options. It works more like ini_set() in that
you pass in the new defaults and it returns the old.
With the current name, it is as bad as if we added an optional argument to ini_get() that would also
set the value.
I know we're already into PHP 5.3 alpha, but this is a simple alias, so I'm hoping you can squeeze it in.
If not, I understand, and will leave that decision to the RM :)
- Davey