Re: [PATCH] Alias stream_context_get_default() as stream_context_set_default()
| From: | Johannes Schlüter | Date: | Mon, 04 Aug 2008 11:02:29 +0000 |
| Subject: | Re: [PATCH] Alias stream_context_get_default() as stream_context_set_default() | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-39624@lists.php.net to get a copy of this message | ||
On Mon, 2008-08-04 at 09:49 +0200, Hannes Magnusson wrote:
> On Mon, Aug 4, 2008 at 01:29, Davey Shafik <davey@php.net> wrote:
> > Hey,
> >
> > it has come to my attention that stream_context_get_default()
> > is /grossly/ misnamed, considering
[...]
> That doesn't really solve anything as the argument is optional.
Adding a new function which enforces the parameter sounds way better
then a simple alias.
> In
> fact, to me it reads like the default context would be reset to
> nothing.
I hope not ... I'd expect it to return the current default context
unchanged, else that function certainly should be replaced....
johannes