Re: zend_call_method() - support for up to 4 parameters

From: Date: Thu, 19 Feb 2009 14:41:32 +0000
Subject: Re: zend_call_method() - support for up to 4 parameters
References: 1 2 3 4 5 6  Groups: php.internals 
Request: Send a blank email to internals+get-43116@lists.php.net to get a copy of this message
did you guys see the other patch i posted yesterday? i re-read Johannes' first reply yesterday and saw the bit about a second api for a zend_call_method with a variable number of parameters. so a made a new function then re-implemented zend_call_method based on that. heres the patch (easier to read on pastebin). http://pastebin.com/m4fd58822 im sure it could be tweaked, but i think the main point is using an array rather than va_list to support the varialbe arg list. is this any better than the first one ? thanks, -nathan

« previous php.internals (#43116) next »