RE: [PHP-DEV] studlyCaps patch
| From: | Lukas Smith | Date: | Fri, 12 Sep 2003 11:29:04 +0000 |
| Subject: | RE: [PHP-DEV] studlyCaps patch | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-4456@lists.php.net to get a copy of this message | ||
> From: Marcus Börger [mailto:marcus.boerger@t-online.de]
> Sent: Friday, September 12, 2003 1:06 PM
> after last discussion on this list regarding PHP's naming convention
for
> OOCode i took a deeper look at fixing my main concerns. That is error
> messages, backtraces and reflection show lowercased method names.
However
> this is easily changeable; with a minor performance decrease at
> compiletime
> when handling methods (not functions).
>
> The attached patch now changes two files for two different purposes:
> 1) Zend/zend_compile.c, These changes allow to show the original
> function/method names in errors, backtraces and reflection. This works
for
> internal as well as for user functions/methods.
>
> 2) Zend/zend_default_classes.c, changes the method names of the
internal
> exception class to studlyCaps naming convention.
> I think decision whether to incorporate this patch is up to Zeev and
Andi.
I am +1 on this obviously.
However it is important to note that this is also useful for userland
code, so I am +1 on this regardless of the php OO CS.
Regards,
Lukas