Re: fopen_wrappers.c DOCUMENT_ROOT .htaccess error

From: Date: Sun, 02 Aug 2009 10:23:06 +0000
Subject: Re: fopen_wrappers.c DOCUMENT_ROOT .htaccess error
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-45179@lists.php.net to get a copy of this message
Jani Taskinen wrote: [snip] There is a bug in 5.2.10 that might cause this, try latest SVN checkout of PHP_5_2 branch, it should be fixed now. I've download and tested the latest snap (php5.2-200908020630) and I am still having the same issue. I have performed an strace with the following result: 6717 stat("/home/c-web/cf/4e/tweek.com.au/public/www/index.php", 0x7fff6adf59a0) = -1 ENOENT (No such file or directory) 6717 lstat("/home", {st_mode=S_IFDIR|0755, st_size=61440, ...}) = 0 6717 lstat("/home/c-web", {st_mode=S_IFDIR|0777, st_size=4096, ...}) = 0 6717 lstat("/home/c-web/cf", {st_mode=S_IFDIR|0755, st_size=8192, ...}) = 0 6717 lstat("/home/c-web/cf/4e", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0 6717 lstat("/home/c-web/cf/4e/tweek.com.au", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0 6717 lstat("/home/c-web/cf/4e/tweek.com.au/public", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0 6717 lstat("/home/c-web/cf/4e/tweek.com.au/public/www", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0 6717 lstat("/home/c-web/cf/4e/tweek.com.au/public/www/index.php", 0x7fff6adf59a0) = -1 ENOENT (No such file or directory) 6717 stat("/home/c-web/cf/4e/tweek.com.au/public/www/index.html", {st_mode=S_IFREG|0644, st_size=14369, ...}) = 0 6717 lstat("/home", {st_mode=S_IFDIR|0755, st_size=61440, ...}) = 0 6717 lstat("/home/c-web", {st_mode=S_IFDIR|0777, st_size=4096, ...}) = 0 6717 lstat("/home/c-web/cf", {st_mode=S_IFDIR|0755, st_size=8192, ...}) = 0 6717 lstat("/home/c-web/cf/4e", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0 6717 lstat("/home/c-web/cf/4e/tweek.com.au", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0 6717 lstat("/home/c-web/cf/4e/tweek.com.au/logs", {st_mode=S_IFDIR|0771, st_size=4096, ...}) = 0 6717 lstat("/home/c-web/cf/4e/tweek.com.au/logs/php_err.log", {st_mode=S_IFREG|0644, st_size=2036814, ...}) = 0 6717 --- SIGSEGV (Segmentation fault) @ 0 (0) --- The apache_error_log is also reporting some errors when I have the error_log enabled in the .htaccess file: [snip apache_error_log] (process:3857): GLib-WARNING **: getpwuid_r(): failed due to: Permission denied. [notice] child pid 6216 exit signal Segmentation fault (11) [end snip] I think I found the original bug report, http://bugs.php.net/bug.php?id=48993&edit=1, which has a similar strace output and is reported to have been fixed however I do believe this is the same bug and it still is unresolved. Should we create a new bug entry or reopen #48993? Hopefully the additional information will provide some assistance in tracking this one down.

« previous php.internals (#45179) next »