Re: [RFC] Array Dereferencing

From: Date: Wed, 09 Jun 2010 17:44:12 +0000
Subject: Re: [RFC] Array Dereferencing
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-48712@lists.php.net to get a copy of this message
On 2010-06-09 16:06:37 +0200, Ferenc Kovacs said:
In fact the uniq problem i see, is could be a name conflict like : function Foo() { // ... } class Foo() { public __create() { // ... } } Foo(); // Instanciate the class or call the function ?
And I think that this is a much higher cost, that we gain. If we want this functionality, then Mathieu Suen's idea is better IMHO: http://www.mail-archive.com/internals@lists.php.net/msg46764.html eg. (new Foo())->bar() Tyrael
Yes my only possible objection is that's less readable. -- Alban Leroux seza@paradoxal.org Web developper

« previous php.internals (#48712) next »