Re: Re[2]: [PHP-DEV] Proposal: Array syntax
| From: | Dirkjan Ochtman | Date: | Wed, 05 Nov 2003 11:45:48 +0000 |
| Subject: | Re: Re[2]: [PHP-DEV] Proposal: Array syntax | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-5207@lists.php.net to get a copy of this message | ||
I like it a lot as well. Having the [] syntax also support range()-like
calls would be a very nice idea as well. :D
Regards,
Manuzhai
"Mike Robinson" <mike@fiddy8.com> wrote in message
news:PPEJIJHNCLOJJONNJNMJCEKPCAAA.mike@fiddy8.com...
> s0niX wrote:
>
> > The problem i see when using array() (or list()) is that it nearly looks
> > like it is a function, but it isn't. Using [] instead would clearly
> > mark this difference.
> > array() and list() are special language constructs, why shouldn't
> > they look a bit special?
> > This doesn't break backwards compatibility and it makes new code look
> > better and more readable.
> >
>
> Indeed. It's a nice idea.
> Having that syntax as an alternative to list() would be cool too.
>
> Whether it has enough steam to get around the magic rule I'll
> leave to others, because the rule is there for a reason. :)
>
> Best Regards
> Mike Robinson
>
>
> >
> > Am Mittwoch, 5. November 2003 um 09:49 schrieben Sie:
> >
> > AG> Hi Christian,
> >
> > AG> Personally I don't like having two ways of doing things. It
> > makes it harder
> > AG> for people to read scripts.
> > AG> However, I think the proposed syntax is significantly more
> > elegant than
> > AG> today's array() which makes me think twice about the idea and
> > possibly
> > AG> making an exception to the rule. I think it'll improve the
> > look of PHP
> > AG> scripts. Also I think people calling methods using
> > call_user_method([$obj,
> > AG> "method"]); will find it sexier than the array() syntax.
> > AG> I guess I think it'd be interesting to see what other's think. Also,
> > AG> another point to check is if list() can also be converted
> > into [] because
> > AG> having a hybrid wouldn't be too nice.
> >
> > AG> Andi
> >
> > AG> At 12:33 AM 11/5/2003 +0100, Christian Schneider wrote:
> > >>I propose to add an alternative (backward compatible) short
> > array creation
> > >>syntax:
> > >>$a = [ 1, 2, 3 ]; and $a = [ 'a' => 42, 'b' =>
> > >>"foo" ];
> > >>
> > >>It can also be used in function calls:
> > >>img(['src' => "logo.gif", 'alt' =>
> > >>"Logo"]);
> > >>
> > >>Reason behind this change: Arrays are used a lot and should
> > therefore have
> > >>as little syntactic overhead as possible. And I think the short
> > syntax is
> > >>also easier to read and write.
> > >>
> > >>A patch for the parser is trivial and is attached for Zend2.
> > >>
> > >>Note: I checked the newsgroup archive but couldn't find a
> > discussion about
> > >>this. After not hearing back about my proposed enhancement to
> > >>debug_backtrace() and the dangling comma for function call parameters
> > >>being rejected I wonder if I'm using the right mailing list for this
:-)
> > >>