Re: Proposal: Array syntax
| From: | Ilia Alshanetsky | Date: | Wed, 05 Nov 2003 15:56:51 +0000 |
| Subject: | Re: Proposal: Array syntax | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-5220@lists.php.net to get a copy of this message | ||
On November 5, 2003 10:34 am, Christian Schneider wrote:
> PHP is a mix of C, Perl and other styles anyway, why deny it? It's
> strength is that it's a pragmatic and simple language but that doesn't
> mean that nothing should be changed ever.
PHP strength (IMHO) is it's simple and clear syntax, which allows people who
come from background in other programming languages can quickly recognize and
get used to. Creating confusing alternate syntaxes will bring us ever closer
to Perl 6 where there are dozens of way to do the same thing. The end results
in a confusing and hard to read/write language that all but the most
dedicated of users refuse to use.
> I don't want to break existing programs. And I don't care about range()
> (or even list() too much for that matter), I just recognize the fact the
> I'm using a lot of array() and it is both unnecessarily hard to write
> _and_ read.
That's bull, 5 characters is hard to write? If anything those 5 characters
make it absolutely clear to ANYONE that the data is an array and not an
object or a string or some other type. When I first saw the syntax is took me
a few seconds to realize what it does and the problem would only be
compounded when the code is found within an pre-existing complex script.
Ilia