Re: Re: cvs: php-src /tests/classes array_access_001.phpt array_access_002.phpt array_access_003.phpt array_access_004.phpt ZendEngine2
zend_execute.c zend_interfaces.c zend_interfaces.h zend_object_handlers.c zend_operators.c zend_operators.h

From: Date: Tue, 25 Nov 2003 05:57:30 +0000
Subject: Re: Re: cvs: php-src /tests/classes array_access_001.phpt array_access_002.phpt array_access_003.phpt array_access_004.phpt ZendEngine2
zend_execute.c zend_interfaces.c zend_interfaces.h zend_object_handlers.c zend_operators.c zend_operators.h
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-5706@lists.php.net to get a copy of this message
And how about calling it Indexable, or something that can be used in a "is a" sentence? As in, you could say "MyArray is an Indexable", but "MyArray is an ArrayAccess" sounds just wrong ;) Cheers, Michael Marcus Boerger wrote:
Hello Sebastian, Monday, November 24, 2003, 10:37:50 PM, you wrote:
Marcus Boerger wrote:
Log: Add new interface ArrayAccess to use objects as Arrays
How about a ZEND_CHANGES entry for this?
Sure, keep cool :-)
-- Sebastian Bergmann
http://sebastian-bergmann.de/                   http://phpOpenTracker.de/
Das Buch zu PHP 5: http://professionelle-softwareentwicklung-mit-php5.de/


« previous php.internals (#5706) next »