Re: Re: cvs: php-src /tests/classes array_access_001.phpt array_access_002.phpt array_access_003.phpt array_access_004.phpt ZendEngine2
zend_execute.c zend_interfaces.c zend_interfaces.h zend_object_handlers.c zend_operators.c zend_operators.h

From: Date: Tue, 25 Nov 2003 10:10:20 +0000
Subject: Re: Re: cvs: php-src /tests/classes array_access_001.phpt array_access_002.phpt array_access_003.phpt array_access_004.phpt ZendEngine2
zend_execute.c zend_interfaces.c zend_interfaces.h zend_object_handlers.c zend_operators.c zend_operators.h
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-5711@lists.php.net to get a copy of this message
Hello Michael, Tuesday, November 25, 2003, 6:57:30 AM, you wrote: > And how about calling it Indexable, or something that can be used in a > "is a" sentence? As in, you could say "MyArray is an Indexable", but > "MyArray is an ArrayAccess" sounds just wrong ;) is_a() is deprecated use instanceof now and that works with any class name. (We are not SQL here) Besides that the patch took about half a year of writing, discussion and planning and i was hoping we finally chose good names. Can you live with them? -- Best regards, Marcus mailto:helly@php.net

« previous php.internals (#5711) next »