RE: [PHP-DEV] Re: [PHP-CVS] cvs: php-src / CODING_STANDARDS

From: Date: Wed, 03 Dec 2003 15:23:20 +0000
Subject: RE: [PHP-DEV] Re: [PHP-CVS] cvs: php-src / CODING_STANDARDS
Groups: php.internals 
Request: Send a blank email to internals+get-6098@lists.php.net to get a copy of this message
> Do you think this inconsistency is worth it, even if it turns out that most > of our bindings turn out to choose studyCaps? Certainly. And I am pretty sure that many binding authors will understand why uglyCaps are largely inferior in the area of comprehension. > No doubt the non studlyCaps version is easier to read (btw in the studlyCaps > version the first char should be lowercased). However is this a real > scenario? How many words will there be in a method name? I have seen Windows identifiers which are nearly that length. I don't mind elaborated identifiers, but whatever their length is, they need to be readable. - Sascha

« previous php.internals (#6098) next »