Re: [DRAFT RFC] Adding Simplified Password Hashing API

From: Date: Fri, 29 Jun 2012 07:16:39 +0000
Subject: Re: [DRAFT RFC] Adding Simplified Password Hashing API
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-61036@lists.php.net to get a copy of this message
hi Anthony, On Thu, Jun 28, 2012 at 9:36 PM, Anthony Ferrara <ircmaxell@gmail.com> wrote: >> I haven't looked at your patch. But if it has to call another >> PHP_FuNCTION then it's not good. crypt implementation should be >> accessible via C. > > I've refactored crypt() slightly to expose a PHP_API crypt_execute() > function that does just about everything except the argument parsing / > default randomizing. > > https://github.com/ircmaxell/php-src/blob/hash_password/ext/standard/crypt.c It looks good. I would name it php_crypt instead. _execute means there is a prepare (well, there is but it is called on init :). Cheers, -- Pierre @pierrejoye | http://blog.thepimp.net | http://www.libgd.org

« previous php.internals (#61036) next »