Re: re: removing an item from an array

From: Date: Tue, 21 Aug 2012 21:53:00 +0000
Subject: Re: re: removing an item from an array
References: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18  Groups: php.internals 
Request: Send a blank email to internals+get-62369@lists.php.net to get a copy of this message
On Tue, Aug 21, 2012 at 3:45 PM, Andrew Faulds <ajf@ajf.me> wrote: > On 21/08/12 22:43, Levi Morrison wrote: >> >> There is a reason to have a callable provided: custom comparison. >> Other array functions solve this by providing a u >> alternative: >> >> int array_udelete(&$array, $value, bool function($value, >> $key)) >> >> Let's not deviate from established array naming conventions. (Yasuo, >> I'm looking at you) >> >> Cheers, >> >> Levi Morrison > > Yeah, this looks like a good solution and we have the best of both worlds. > > We get int array_delete(&$array, $value, $strict=TRUE); and int > array_udelete(&$array, $value, $callback=bool function ($value $key)); > > :) > > I'll still vote no on the RFC if it ever comes to it :) I'm only contributing here because I don't want pure madness to ever come to a vote when I'm absent and get voted in . . .

« previous php.internals (#62369) next »