[PHP6] Merging rand and mt_rand()

From: Date: Sun, 23 Feb 2014 18:45:24 +0000
Subject: [PHP6] Merging rand and mt_rand()
Groups: php.internals 
Request: Send a blank email to internals+get-72772@lists.php.net to get a copy of this message
Hello internals, there has already been a lot of talk about improving secure random number generation for PHP6. One thing I'd like to improve as well, would be non-secure random number generation. Here is not so much security at stake but ease of use. The obvious solution, would be to rename mt_rand to rand and make rand an alias. (The same for the supporting functions mt_srand and mt_getrandmax). What I'm missing is the history. What was the reason to keep the separate? Am I missing something? Best regards Rouven

« previous php.internals (#72772) next »