Re: [PHP6] Merging rand and mt_rand()
| From: | Rouven Weßling | Date: | Mon, 24 Feb 2014 13:03:33 +0000 |
| Subject: | Re: [PHP6] Merging rand and mt_rand() | ||
| References: | 1 2 3 4 5 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-72793@lists.php.net to get a copy of this message | ||
On 24.02.2014, at 00:01, Rouven Weßling <me@rouvenwessling.de> wrote:
> Maybe it would be a good idea to deprecate those and not include them in PHP6? It's
> probably safer to provide a dedicated sequence generator, than having people abuse our PRNGs.
Coming back to this, I hacked up a sequence generator we could include PHP 5.x to reduce these
concerns: https://github.com/realityking/php-src/compare/php:master...realityking:sequenceGenerator
If there's interest in this, I'd clean it up (lots of duplicated code between mt_rand and
this right now) and propose it for 5.7.
Best regards
Rouven