Re: Re: Revert session_serializer_name(), session_gc()
| From: | Yasuo Ohgaki | Date: | Sat, 15 Mar 2014 00:20:49 +0000 |
| Subject: | Re: Re: Revert session_serializer_name(), session_gc() | ||
| References: | 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-73171@lists.php.net to get a copy of this message | ||
Hi all,
On Fri, Mar 14, 2014 at 7:44 PM, Andrey Andreev <narf@devilix.net> wrote:
> It is not broken functionally, indeed.
> It's broken by design - if I write session_start(), options or not, I
> would never expect it to immediately close the session. It's highly
> misleading and this will lead to a lot of abuse.
>
I don't want to confuse users.
Better name would be appreciated.
Perhaps, "close" may be better option name.
session_start(['read_only'=>true]);
↓
session_start(['close']=>true);
Any comments/better names?
Regards,
--
Yasuo Ohgaki
yohgaki@ohgaki.net