Re: Re: Revert session_serializer_name(), session_gc()
| From: | Andrey Andreev | Date: | Sat, 15 Mar 2014 02:32:59 +0000 |
| Subject: | Re: Re: Revert session_serializer_name(), session_gc() | ||
| References: | 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-73172@lists.php.net to get a copy of this message | ||
Hi,
On Sat, Mar 15, 2014 at 2:20 AM, Yasuo Ohgaki <yohgaki@ohgaki.net> wrote:
> Hi all,
>
> On Fri, Mar 14, 2014 at 7:44 PM, Andrey Andreev <narf@devilix.net> wrote:
>>
>> It is not broken functionally, indeed.
>> It's broken by design - if I write session_start(), options or not, I
>> would never expect it to immediately close the session. It's highly
>> misleading and this will lead to a lot of abuse.
>
>
> I don't want to confuse users.
> Better name would be appreciated.
>
> Perhaps, "close" may be better option name.
>
> session_start(['read_only'=>true]);
> ↓
> session_start(['close']=>true);
>
> Any comments/better names?
I'd rather suggest this to be a separate function and not an option
for session_start(). I've got this coverered in a draft RFC that I
will announce for discussion later today.
Now back to the main topic:
Please exclude session_serializer_name(), session_gc(),
session_reset(), session_abort() and the "session write short-circuit"
from the 5.6 branch.
Cheers,
Andrey.