Re: [phpng] naming

From: Date: Wed, 07 May 2014 10:33:21 +0000
Subject: Re: [phpng] naming
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-74006@lists.php.net to get a copy of this message
I would be just glad. Having clear uniform naming would be fine. We should just come to agreement about the actual names and I don't think it's a big problem. Thanks. Dmitry. On Wed, May 7, 2014 at 12:54 PM, Pierre Joye <pierre.php@gmail.com> wrote: > hi, > > would it be possible to "clean up" the naming while being at it? > > I would prefer longer but clearer/less confusing names rather than > trying to reduce the type strokes. > > For example: > > ZVAL_ARR() > ZVAL_ARRAY > ZVAL_NEW_ARR() > ZVAL_NEW_ARRAY (btw, ZVAL_NEW_ARRAY is wrongly > documented in the wiki draft, section about arrays) > > Other engine's APIs use full names, to go back and forth between these > convention is error prone and not too clean. Thoughts? > > Yes, it is a detail, but better to fix this now than latter :) > > Cheers, > -- > Pierre > > @pierrejoye | http://www.libgd.org > > -- > PHP Internals - PHP Runtime Development Mailing List > To unsubscribe, visit: http://www.php.net/unsub.php > >

« previous php.internals (#74006) next »