Re: [RFC] ReflectionParameter::hasTypehint() / getTypehintText()

From: Date: Mon, 02 Jun 2014 15:26:48 +0000
Subject: Re: [RFC] ReflectionParameter::hasTypehint() / getTypehintText()
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-74700@lists.php.net to get a copy of this message
On Sun, Jun 1, 2014 at 5:38 PM, Levi Morrison <levim@php.net> wrote: > We might want to rename ReflectionTypeAnnotation::isNullable to > ReflectionTypeAnnotation::allowsNull. I think it is a bit more > understandable; it also is used by ReflectionParmeter so it > would be > a bit more consistent. What do you think? > Absent pre-existing uses, I like following the is*() pattern of isArray/isCallable for consistency. But good catch, it's probably best to avoid inconsistency with the parent class. -Sara

« previous php.internals (#74700) next »