Re: [DRAFT][RFC] Big Integer Support
| From: | Rowan Collins | Date: | Thu, 26 Jun 2014 17:33:50 +0000 |
| Subject: | Re: [DRAFT][RFC] Big Integer Support | ||
| References: | 1 2 3 4 5 6 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-75098@lists.php.net to get a copy of this message | ||
Chris Wright wrote (on 26/06/2014):
An interesting thought. Is there really much value in renaming it though? It would cause a compatibility break (once the deprecation period expired) for something which could easily be covered by documentation. If done right, the BigInt support would simply make the constant unnecessary in the majority of cases. It's also not entirely clear to me what it could be renamed *to* which was any more appropriate. P.S. You hit "reply" instead of "reply list" or "reply to all", so your message missed the list. -- Rowan Collins [IMSoP]I'm assuming if bigint keys were available, PHP_INT_MAX would still have the same value, but PHP_INT_MAX + 1 would become a valid key, making this work transparently.PHP_INT_MAX would probably need to be renamed (i.e. deprecated and replaced) because it would become a misnomer - the max*PHP* int is no longer known because it is limited only by memory.