Re: Re: cvs: php-src / php.ini-dist php.ini-recommended /sapi/cgi cgi_main.c

From: Date: Tue, 10 Feb 2004 22:18:02 +0000
Subject: Re: Re: cvs: php-src / php.ini-dist php.ini-recommended /sapi/cgi cgi_main.c
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-7714@lists.php.net to get a copy of this message
At 00:10 11/02/2004, Rasmus Lerdorf wrote:
On Tue, 10 Feb 2004, Derick Rethans wrote: On Tue, 10 Feb 2004, Andi Gutmans wrote:
Well we do tend to be verbose in PHP even when it's non-standard. I'd really prefer cgi.non_parsing_headers.
It should be common_gateway_interface.non_parsing_headers then... Yeah, nph is pretty much as well-known as cgi. The people who are affected by this will all know and understand "nph".
I wouldn't say nph is nearly as well known as CGI, but either way, is there any reason not to go with something more verbose? I do agree that most people who need nph would know what it is, but even for people that do, a more verbose name doesn't reduce readability (as long as we don't get carried away with common_gateway_interface...). It's no biggy either way, but I do think that we're better off using no_header_parsing or something like that. Zeev

« previous php.internals (#7714) next »