Re: Re: cvs: php-src / php.ini-dist php.ini-recommended /sapi/cgi cgi_main.c

From: Date: Tue, 10 Feb 2004 22:52:36 +0000
Subject: Re: Re: cvs: php-src / php.ini-dist php.ini-recommended /sapi/cgi cgi_main.c
References: 1 2 3 4 5 6  Groups: php.internals 
Request: Send a blank email to internals+get-7718@lists.php.net to get a copy of this message
On Wed, 11 Feb 2004, Zeev Suraski wrote: > At 00:10 11/02/2004, Rasmus Lerdorf wrote: > >On Tue, 10 Feb 2004, Derick Rethans wrote: > > > > > On Tue, 10 Feb 2004, Andi Gutmans wrote: > > > > > > > Well we do tend to be verbose in PHP even when it's non-standard. > > > > I'd really prefer cgi.non_parsing_headers. > > > > > > It should be common_gateway_interface.non_parsing_headers then... > > > >Yeah, nph is pretty much as well-known as cgi. The people who are > >affected by this will all know and understand "nph". > > I wouldn't say nph is nearly as well known as CGI, but either way, is there > any reason not to go with something more verbose? I do agree that most > people who need nph would know what it is, but even for people that do, a > more verbose name doesn't reduce readability (as long as we don't get > carried away with common_gateway_interface...). Well, I would grep or search in my editor for "nph" if I was looking for a toggle for this. My search would not find the more verbose directive. -Rasmus

« previous php.internals (#7718) next »