Re: Re: [ZEND-ENGINE-CVS] cvs: ZendEngine2 /
| From: | Steven D. Nowicki | Date: | Tue, 17 Feb 2004 03:37:49 +0000 |
| Subject: | Re: Re: [ZEND-ENGINE-CVS] cvs: ZendEngine2 / | ||
| References: | 1 2 3 4 5 6 7 8 9 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-7897@lists.php.net to get a copy of this message | ||
Timm Friebe wrote:
I think if you're going to rename Throwable to IException, the naming scheme for the other built-in interfaces should be consistent. Traversable, Iterator, IteratorAggregate, and ArrayAccess should be renamed ITraversable, IIterator, IIteratorAggregate, and IArrayAccess. Same should apply to any other built-ins that I'm forgetting. - SteveAndi P.S. - BTW, why not call it IException (or ExceptionInterface) instead of Throwable? I think for people who don't know Java, it makes more sense.Agreed. An updated patch is attached. - Timm