Re: Iterator Class/foreach Logic Flaw?

From: Date: Thu, 26 Feb 2004 20:43:40 +0000
Subject: Re: Iterator Class/foreach Logic Flaw?
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-8186@lists.php.net to get a copy of this message
Sorry for follow-up to myself, but it would be somewhat easier to just rename hasMore() to isValid() and then implement hasMore() after PHP5 goes gold. Philip Fletcher wrote: > Whilst I appreciate adding an isValid() method to the Iterator interface > is not trivial (and I am loath to suggest a change this close to PHP RC > phase) ...

« previous php.internals (#8186) next »