Re: Iterator Class/foreach Logic Flaw?
| From: | Marcus Boerger | Date: | Thu, 26 Feb 2004 21:03:04 +0000 |
| Subject: | Re: Iterator Class/foreach Logic Flaw? | ||
| References: | 1 2 3 4 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-8187@lists.php.net to get a copy of this message | ||
Hello Philip,
just to make it clear. hasMore() would be the exact same then isValid()
only the name would change. The semantic is already what you refer to as
isValid.
Thursday, February 26, 2004, 9:43:40 PM, you wrote:
> Sorry for follow-up to myself, but it would be somewhat easier to just
> rename hasMore() to isValid() and then implement hasMore() after PHP5 goes
> gold.
> Philip Fletcher wrote:
>> Whilst I appreciate adding an isValid() method to the Iterator interface
>> is not trivial (and I am loath to suggest a change this close to PHP RC
>> phase) ...
--
Best regards,
Marcus mailto:helly@php.net